Moxa NPort 5110A 1-port RS-232 serial device servers with serial surge protection
Introduction
Moxa NPort 5110A device servers are designed to make serial devices network-ready in an instant and give your PC software direct access to serial devices from anywhere on the network. Moxa NPort 5110A device servers are ultra-lean, ruggedized, and user-friendly, making simple and reliable serial-to-Ethernet solutions possible.
A Greener Serial-to-Ethernet Solution
The MiiNe is a small but powerful Arm-based serial-to-Ethernet SoC with RAM and Flash embedded. With the MiiNe inside, Moxa NPort 5110A's power consumption is less than 1 W. Moxa NPort 5110A saves at least 50% on power consumption compared to existing solutions on the market, helping engineers meet the tough environmental compliance challenges found in today's industrial environments.
Surge Protection for Serial, Ethernet, and Power
Surge, which is typically caused by high voltages that result from switching and lightning transients, is a common threat to all electrical devices. Moxa's leading-edge surge immunity solution, which is applied to the Moxa NPort 5110A's serial, power, and Ethernet lines, is tested and proven compliant with IEC 61000-4-5. This state-of-the-art surge protection provides a robust serial-to-Ethernet solution that can protect electrical devices from voltage spikes and withstand electrically noisy environmental conditions.
3-Step Web-based Configuration
Moxa NPort 5110A's 3-step web-based configuration tool is straightforward and user-friendly. Moxa NPort 5110A's web console guides users through three simple configuration steps that are necessary to activate the serial-to-Ethernet application. With this fast 3-step web-based configuration, a user only needs to spend an average of 30 seconds to complete the NPort settings and enable the application, saving a great amount of time and effort.
Easy to Troubleshoot
Moxa NPort 5110A device servers support SNMP, which can be used to monitor all units over Ethernet. Each unit can be configured to send trap messages automatically to the SNMP manager when user-defined errors are encountered. For users who do not use SNMP manager, an email alert can be sent instead. Users can define the trigger for the alerts using Moxa's Windows utility, or the web console. For example, alerts can be triggered by a warm start, a cold start, or a password change.
Features and Benefits
- Power consumption of only 1 W
- Fast 3-step web-based configuration
- Surge protection for serial, Ethernet, and power
- COM port grouping and UDP multicast applications
- Screw-type power connectors for secure installation
- Real COM and TTY drivers for Windows, Linux, and macOS
- Standard TCP/IP interface and versatile TCP and UDP operation modes
- Connects up to 8 TCP hosts
Appearance

Specifications
Ethernet Interface
|
10/100BaseT(X) Ports (RJ45 connector) |
1 |
|
Magnetic Isolation Protection |
1.5 kV (built-in) |
Ethernet Software Features
|
Configuration Options |
Windows Utility, Web Console (HTTP/HTTPS), Device Search Utility (DSU), MCC Tool, Telnet Console, Serial Console (NPort 5110A/5150A models only) |
|
Management |
DHCP Client, ARP, BOOTP, DNS, HTTP, HTTPS, ICMP, IPv4, LLDP, SMTP, SNMPv1/ v2c, TCP/IP, Telnet, UDP |
|
Filter |
IGMP v1/v2 |
|
Windows Real COM Drivers |
Windows 95/98/ME/NT/2000, Windows XP/2003/Vista/2008/7/8/8.1/10/11 (x86/x64), Windows 2008 R2/2012/2012 R2/2016/2019 (x64), Windows Server 2022, Windows Embedded CE 5.0/6.0, Windows XP Embedded |
|
Linux Real TTY Drivers |
Kernel versions: 2.4.x, 2.6.x, 3.x, 4.x, and 5.x |
|
Fixed TTY Drivers |
macOS 10.12, macOS 10.13, macOS 10.14, macOS 10.15, SCO UNIX, SCO OpenServer, UnixWare 7, QNX 4.25, QNX 6, Solaris 10, FreeBSD, AIX 5.x, HP-UX 11i, Mac OS X |
|
Android API |
Android 3.1.x and later |
|
MIB |
RFC1213, RFC1317 |
Security Functions
|
Authentication |
Local database |
|
Encryption |
HTTPS, AES-128, SHA-1, RSA-1024, SHA-256 |
|
Security Protocols |
HTTPS (TLS 1.2) |
Serial Interface
|
Connector |
DB9 male |
|
No. of Ports |
1 |
|
Serial Standards |
NPort 5110A: RS-232 NPort 5130A: RS-422, RS-485 NPort 5150A: RS-232, RS-422, RS-485 |
|
Operation Modes |
Disabled, Ethernet Modem, Pair Connection, Real COM, Reverse Telnet, RFC2217, TCP Client, TCP Server, UDP |
|
Baudrate |
Supports standard baudrates (unit=bps): 50, 75, 110, 134, 150, 300, 600, 1200, 1800, 2400, 4800, 7200, 9600, 19200, 38400, 57600, 115200, 230.4k, 460.8k, 921.6k |
|
Data Bits |
5, 6, 7, 8 |
|
Stop Bits |
1, 1.5, 2 |
|
Parity |
None, Even, Odd, Space, Mark |
|
Flow Control |
RTS/CTS (RS-232 only), DTR/DSR (RS-232 only), XON/XOFF |
|
Pull High/Low Resistor for RS-485 |
1 kilo-ohm, 150 kilo-ohms |
|
RS-485 Data Direction Control |
NPort 5150A/5150A-T/5130A/5130A-T: ADDC (automatic data direction control) |
|
Terminator for RS-485 |
120 ohms |
Serial Signals
|
RS-232 |
TxD, RxD, RTS, CTS, DTR, DSR, DCD, GND |
|
RS-422 |
Tx+, Tx-, Rx+, Rx-, GND |
|
RS-485-4w |
Tx+, Tx-, Rx+, Rx-, GND |
|
RS-485-2w |
Data+, Data-, GND |
Power Parameters
|
No. of Power Inputs |
1 |
|
Input Current |
NPort 5110A: 82.5 mA @ 12 VDC NPort 5130A: 89.1 mA @ 12 VDC NPort 5150A: 92.4 mA @ 12 VDC |
|
Input Voltage |
12 to 48 VDC |
|
Source of Input Power |
Power input jack |
Reliability
|
Automatic Reboot Trigger |
Built-in WDT |
Physical Characteristics
|
Housing |
Metal |
|
Dimensions (with ears) |
75.2 x 80 x 22 mm (2.96 x 3.15 x 0.87 in) |
|
Dimensions (without ears) |
52 x 80 x 22 mm (2.05 x 3.15 x 0.87 in) |
|
Weight |
340 g (0.75 lb) |
|
Installation |
Desktop, DIN-rail mounting (with optional kit), Wall mounting |
Environmental Limits
|
Operating Temperature |
Standard Models: 0 to 60°C (32 to 140°F) Wide Temp. Models: -40 to 75°C (-40 to 167°F) |
|
Storage Temperature (package included) |
-40 to 75°C (-40 to 167°F) |
|
Ambient Relative Humidity |
5 to 95% (non-condensing) |
Standards and Certifications
|
EMC |
EN 55032/35 |
|
EMI |
CISPR 32, FCC Part 15B Class A |
|
EMS |
IEC 61000-4-2 ESD: Contact: 6 kV; Air: 8 kV IEC 61000-4-3 RS: 80 MHz to 1 GHz: 10 V/m IEC 61000-4-4 EFT: Power: 2 kV; Signal: 1 kV IEC 61000-4-5 Surge: Power: 2 kV; Signal: 0.5 kV IEC 61000-4-6 CS: 150 kHz to 80 MHz: 10 V/m; Signal: 10 V/m IEC 61000-4-8 PFMF IEC 61000-4-11 |
|
Safety |
UL 60950-1 |
Declaration
|
Green Product |
RoHS, CRoHS, WEEE |
MTBF
|
Time |
2,231,530 hrs |
|
Standards |
Telcordia (Bellcore) Standard TR/SR |
Package Contents
|
Device |
1 x NPort 5100A Series device server |
|
Power Supply |
1 x power adapter, suitable for your region (standard temp. models only) |
|
Documentation |
1 x quick installation guide 1 x warranty card |
Dimensions

Ordering Information
|
Model Name |
Operating Temp. |
Baudrate |
Serial Standards |
No. of Serial Ports |
Input Current |
Input Voltage |
|
NPort 5110A |
0 to 60°C |
50 bps to 921.6 kbps |
RS-232 |
1 |
82.5 mA @ 12 VDC |
12-48 VDC |
|
NPort 5110A-T |
-40 to 75°C |
50 bps to 921.6 kbps |
RS-232 |
1 |
82.5 mA @ 12 VDC |
12-48 VDC |
|
NPort 5130A |
0 to 60°C |
50 bps to 921.6 kbps |
RS-422/485 |
1 |
89.1 mA @ 12 VDC |
12-48 VDC |
|
NPort 5130A-T |
-40 to 75°C |
50 bps to 921.6 kbps |
RS-422/485 |
1 |
89.1 mA @ 12 VDC |
12-48 VDC |
|
NPort 5150A |
0 to 60°C |
50 bps to 921.6 kbps |
RS-232/422/485 |
1 |
92.4 mA @ 12 VDC |
12-48 VDC |
|
NPort 5150A-T |
-40 to 75°C |
50 bps to 921.6 kbps |
RS-232/422/485 |
1 |
92.4 mA @ 12 VDC |
12-48 VDC |
Accessories (sold separately)
Cables
|
CBL-F9M9-20 |
DB9 female to DB9 male serial cable, 20 cm |
|
CBL-F9M9-150 |
DB9 female to DB9 male serial cable, 1.5 m |
Connectors
|
ADP-RJ458P-DB9F |
DB9 female to RJ45 connector |
|
Mini DB9F-to-TB |
DB9 female to terminal block connector |
DIN-Rail Mounting Kits
|
DK35A |
DIN-rail mounting kit, 35 mm |
Power Adapters
|
PWR-12050-WPAU-S1 |
Locking barrel plug, 12 VDC, 0.5 A, 100 to 240 VAC, Australia (AU) plug, 0 to 40°C operating temperature |
|
PWR-12050-WPCN-S1 |
Locking barrel plug, 12 VDC, 0.5 A, 100 to 240 VAC, China (CN) plug, 0 to 40°C operating temperature |
|
PWR-12050-WPEU-S1 |
Locking barrel plug, 12 VDC, 0.5 A, 100 to 240 VAC, Continental Europe (EU) plug, 0 to 40°C operating temperature |
|
PWR-12050-WPUK-S1 |
Locking barrel plug, 12 VDC, 0.5 A, 100 to 240 VAC, United Kingdom (UK) plug, 0 to 40°C operating temperature |
|
PWR-12050-WPUSJP-S1 |
Locking barrel plug, 12 VDC, 0.5 A, 100 to 240 VAC, United States/Japan (US/JP) plug, 0 to 40°C operating temperature |
|
PWR-12150-AU-SA-T |
Locking barrel plug, 12 VDC, 1.5 A, 100 to 240 VAC, Australia (AU) plug, -40 to 75°C operating temperature
Applicable Models: NPort 5110A-T NPort 5130A-T NPort 5150A-T |
|
PWR-12150-AU-SA-T |
Locking barrel plug, 12 VDC, 1.5 A, 100 to 240 VAC, Australia (AU) plug, -40 to 75°C operating temperature
Applicable Models: NPort 5110A-T NPort 5130A-T NPort 5150A-T |
|
PWR-12150-CN-SA-T |
Locking barrel plug, 12 VDC, 1.5 A, 100 to 240 VAC, China (CN) plug, -40 to 75°C operating temperature
Applicable Models: NPort 5110A-T NPort 5130A-T NPort 5150A-T |
|
PWR-12150-EU-SA-T |
Locking barrel plug, 12 VDC, 1.5 A, 100 to 240 VAC, Continental Europe (EU) plug, -40 to 75°C operating temperature
Applicable Models: NPort 5110A-T NPort 5130A-T NPort 5150A-T |
|
PWR-12150-UK-SA-T |
Locking barrel plug, 12 VDC, 1.5 A, 100 to 240 VAC, United Kingdom (UK) plug, -40 to 75°C operating temperature
Applicable Models: NPort 5110A-T NPort 5130A-T NPort 5150A-T |
|
PWR-12150-USJP-SA-T |
Locking barrel plug, 12 VDC 1.5 A, 100 to 240 VAC, United States/Japan (US/JP) plug, -40 to 75°C operating temperature
Applicable Models: NPort 5110A-T NPort 5130A-T NPort 5150A-T |
Power Cords
|
CBL-PJ21NOPEN-BK-30 |
Locking barrel plug to bare-wire cable |
Hot Tags: moxa nport 5110a, China, wholesale, online, order, eds 2005 el t, eds 508a, moxa unmanaged switch, eds g205a, Moxa SFP-1GSXLC, tcf 142 m sc



